2010-05-06 1 views
10

¿Qué debería llamar una variable instanciada con algún tipo de matriz?Nombramiento de variables para matrices/listas/colecciones - C#

¿Está bien simplemente usar una forma pluralizada del tipo que se retiene?

IList<Person> people = new List<Person>();

o debería añadir algo así como 'Lista' para el nombre?

IList<Person> personList = new List<Person>();

Además, por lo general es aceptable tener bucles de este tipo?

foreach(string item in items) 
{ 
    //Do something 
} 

Respuesta

3

Como se mencionó anteriormente, esto es realmente muy subjetivo, pero elegiría lo que se ve mejor en el menú desplegable intellisense cuando use las clases, ya que probablemente sea el primer punto de interacción que tendrán otros desarrolladores que usen su código.

11

Esta es la convención de código simple, por lo que debe ir con lo que su equipo está acostumbrado. Si es soltero por proyecto, simplemente siga usando la misma convención sea lo que sea.

LE: el ciclo está bien, aunque es una pregunta distinta.

1

Personalmente, me gustaría ir a "personas", sin embargo, esto es muy subjetivo y no "estándar de codificación". Ve con lo que sientes que es más intuitivo.

Y sí su bucle es perfectamente aceptable

0

Personalmente, creo que un nombre de variable debe describir el tipo, así como el contexto. personalmente me gusta la personList más :) Con todas estas declaraciones 'personalmente', supongo que es sólo mi opinión personal :)

1

En los equipos que he trabajado, que comúnmente se consideran una buena práctica para no diferenciar un list/array variable de una sola variable de objeto, simplemente usando la forma plural del nombre.

I.e. utilizando

object horse = new object(); 

y

List<object> horses = new List<object>; 

va a ser muy difícil cuando se lee el código. Así que hay que ir por algo así como

object horse = new object(); 

y

List<object> PackOfHorses = new List<Object>(); 

como ya lo ha dicho.

Su ciclo es perfectamente aceptable. Nada de malo con eso.

EDITAR: Cambió el fraseo y los nombres de las variables debido a los comentarios.

+2

Como usted es la única persona que ha reclamado "mejores prácticas" en lugar de "esta es solo mi opinión", no estoy de acuerdo con usted. Citación necesaria en su primera oración, porque eso no parece una buena práctica. Ni siquiera la [versión original de la notación húngara] (http://www.joelonsoftware.com/articles/Wrong.html) solicitó que el tipo de datos formara parte del nombre de la variable. Además, ¿desde cuándo es PascalCase una mejor práctica para los nombres de variables? –

+0

Quizás mi redacción no fue del todo correcta. Por "Generalmente se considera la mejor práctica", en realidad quise decir que generalmente se considera 'buena' práctica no solo usar el plurar de una palabra (caballo, caballos), ya que es más difícil de observar al leer el código. No proporcioné cita, porque no he leído/escuchado en un solo lugar. Es solo experiencia. En cuanto al tipo de datos, no dije que debería usarlo, solo usé var nombres similares a la pregunta del OP (usó personsList). En el ejemplo con el caballo que acabo de mencionar, me gustaría ir a caballo - packOfHorses en lugar de horse-horses –

+3

Nunca antes había escuchado a alguien decir que usar el plural para una lista hace que el código sea más difícil de leer. –

1

Idealmente, usaría el plural, aunque hay ocasiones en que podría querer usar el otro formulario. Solo hay pautas, no reglas duras y rápidas.

1

No me gusta usar PersonList ya que suena más como una clase que has escrito para contener personas que una variable.

0

Creo que en los viejos tiempos cuando no había IDEs con todas las funciones, usar nombres como peopleList eran más adecuados ya que podían averiguar el tipo de la variable por su nombre. Pero hoy en día, eso ya no es un problema.