2012-09-10 9 views
8

Acabo de descargar Sonar 3.2 y he configurado los archivos sonar.properties para conectarme a mi base de datos MySql local. He habilitado la siguiente configuración:Configuración de Sonar MySQL

sonar.jdbc.url: jdbc:mysql://localhost:3306/sonar?useUnicode=true&characterEncoding=utf8&rewriteBatchedStatements=true 
sonar.jdbc.driverClassName: com.mysql.jdbc.Driver 

estoy en condiciones de iniciar el servidor sin ningún error y soy capaz de acceder a la interfaz del sonar sin embargo cuando corro 'sónar mvn: sonar' en mi proyecto Maven consigo el siguiente error:

[ERROR] Failed to execute goal org.codehaus.mojo:sonar-maven-plugin:2.0:sonar (default-cli) on project vrservices: Can not execute Sonar: Fail to connect to database: Cannot load JDBC driver class 'org.h2.Driver' -> [Help 1] 

he leído algunos foros que dicen que poner el siguiente código en el archivo settings.xml sin embargo, esto todavía no se ha solucionado el problema.

<profile> 
     <id>sonar</id> 
     <activation> 
      <activeByDefault>true</activeByDefault> 
     </activation> 
     <properties> 
      <!-- EXAMPLE FOR MYSQL --> 
      <sonar.jdbc.url>jdbc:mysql://localhost:3306/sonar?useUnicode=true&amp;characterEncoding=utf8</sonar.jdbc.url> 
      <sonar.jdbc.driver>com.mysql.jdbc.Driver</sonar.jdbc.driver> 
      <sonar.jdbc.username>root</sonar.jdbc.username> 
      <sonar.jdbc.password></sonar.jdbc.password> 
     </properties> 
    </profile> 

Me preguntaba si alguien se ha encontrado con este problema y, en caso afirmativo, ¿cómo lo solucionó?

¡Gracias de antemano!

+0

Parece que Sonar busca la base de datos h2. ¿Estás seguro de haber configurado correctamente todas las propiedades como se describe aquí? http://docs.codehaus.org/display/SONAR/Installing+Sonar – ppapapetrou

Respuesta

7

Si no configura el plugin Maven Sonar, intentará conectarse a la ubicación predeterminada para la base de datos integrada que se envía con Sonar. Comenzando con la versión 3.2, la base de datos incrustada por defecto es H2 (reemplazando derby).

Las recomendaciones del foro son correctas, sospecho que su instancia de Maven no está cargando el archivo de configuración correcto. Intente ejecutar Maven de la siguiente manera:

mvn -s /path/to/settings/file/setting.xml sonar:sonar 
+0

Hola Mark, gracias por tu respuesta. Ejecuté el comando que indicó en su comentario y, desafortunadamente, recibí el mismo mensaje. – Harvey

1

¿Quizás pegó accidentalmente la parte del "perfil" en el lugar incorrecto en su settings.xml? Asegúrese de tenerlo entre las etiquetas <profiles></profiles>. (Un colega mío acaba de tropezar con un problema similar)

6

ver que el atributo 'sonar.jdbc.url' en los archivos settings.xml y sonar.properties es el mismo. en segundo lugar, cree un esquema por nombre 'sonar' antes de intentar ejecutar el servidor de sonar. buena suerte

0

Según @Mark O'Connor respuesta: compruebe si el archivo settings.xml está en la ruta correcta (/home/YOURUSER/.m2/ o la variable de entorno MAVEN_HOME) y que lo ejecuta desde el usuario correcto - cuando ejecuté Sonar Maven Runner como root, no pude acceder al archivo settings.xml, porque lo tenía en la carpeta de inicio de mi usuario.

Cuestiones relacionadas